Describe a small opportunities in 3ds Max that annoy you in your daily work. Please give the steps that show it and describe clearly how you'd prefer it to work. Please include a description!

"New intuitive viewport" navigation in 3DSMax 2015 does not work properly

The "adaptive viewport navigation for smarter zooming, panning, and orbiting" in 3D Studio Max 2015 seems to be malfunctioning more often then not, putting it's focus-point wrong. Beyond that this new way of navigating is an absolute nightmare for large Urban scale scenes, as you tend to have a hyper-sensitive focus point and this simply makes version 2015 unusable. At least give us a choise between navigational systems so we're not stuck to previous versions untill this is sorted out...?

56 votes
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
3dboomerang3dboomerang shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Signed in as (Sign out)
  • Myth_N7Myth_N7 commented  ·   ·  Flag as inappropriate

    I am using 3ds max 2016.
    I have just started noticing this as an issue in the last few days, so I thought I had toggled a setting somehow by accident.
    For sure if my issue is this same issue, but it sounds like it.
    I tried all the solutions in the thread and none of it works for me.
    The thing I have as the issue for me is when I click on open space espically when I had something selected, the viewport will jump its focus somewhere else.

    One thing that is odd how ever is it only seems to affect the bottom right viewport, in 4x mode or in solo mode, toggling by alt+w.

    The other 3 viewports (knock on wood) do not seem to have the issue.
    Other things I have noticed about the viewport which may be related is at some randomly seeming time, the cursor does not properly find the objects, like when trying to select a vert or line, it will change to the hovering over icon when you are in open space near by.
    The fix that seems to work for this is to hit P for perspective, then z to reset space. then hit u again for orto, and usualy this will correct it, but again, its always seeming to be only an issue in this bottom right viewport.


  • stoobz1stoobz1 commented  ·   ·  Flag as inappropriate

    Hey guys, hope this thread is still active.
    Meanwhile I switched to Max2016 and still this super annoying viewport-behaviour didn´t change :(
    already in Max2015 the 3dsMax.ini entry AdaptiveNavigation=0 didn´t work for me. Same thing in Max2016 now.

    I just wanted to ask, if anyone found out something, maybe there is another .ini-entry one could make or some other kind of work around?

    any hint would be much appreciated!!

    thanks and cheers!

  • DexterKDexterK commented  ·   ·  Flag as inappropriate

    At the bottom right of the 3ds max screen, select and hold the pan view fly-out (looks like a hand), and select the 2D Pan Zoom Mode (looks like a hand with a marque-select behind it). This will disable accelerated viewport panning and behave how you would expect while panning.

  • MazerVisualMazerVisual commented  ·   ·  Flag as inappropriate

    I have issues panning with the middle mouse button selected, it will often snap back to where I started from after going to the second screen

  • kiiperkiiper commented  ·   ·  Flag as inappropriate

    I have to zoom in or out while panning to get it work. Otherwise panning is just stuck in place. Zooming seems to change its speed randomly. Problem seems to happen with larger pre 2015 files. These things really makes my life hard.

  • 3dboomerang3dboomerang commented  ·   ·  Flag as inappropriate

    Ricky: they disabled the adaptive navigational system by default for the time being i believe, however, i started a new thread stating it's still not what it was in 2014, check the youtube video here and possible confirm what i'm saying cause not everyone seems to have this problem i'm having:


  • Ricky JohnsonRicky Johnson commented  ·   ·  Flag as inappropriate

    I installed 2015 Ext1 a few months ago and found that the 'adaptive viewport zoom' (focal sampling - whatever you want to term it) renders the software unusable for me. This is not an exaggeration. I have for the time being dodged this disaster by amending the AdaptiveNavigation line in the .ini file. A remedy that has been mentioned in other threads and reverts back to the pre-2015 zoom behaviour. If this had not been the case then I would have ended my monthly subscription right there and then. This is not a 'small annoying' issue to me. It cripples the functionality of the software.

    It has come to my attention that SP3 users are no longer finding that they can successfully use the AdaptiveNavigation=0 amendment in the .ini. Why has the option to revert back to the old navigation style been removed?

    If this remains the case then I will not be able to update this software and it will bring the worth of my ongoing subscription to Autodesk into question. I personally have no interest in a 'fix' to the adaptive navigation style. If you wish to develop such things then go ahead but simply give us the ability back to choose which option works for us.

    Thank you

  • mats.holmbergmats.holmberg commented  ·   ·  Flag as inappropriate

    I thought I might clarify what kind of problems persist. Oribitng now (after SP2, I guess) works reasonably fine, given you untick the "Zoom About Mouse Point (perspective)" button.
    Panning is changing speeds seemingly at random. I center the view on a subobject, orbit around it, then start panning. At times the panning works fine, but suddenly it just throws the model out of view.
    Same goes for zooming. I center the view and start zooming. First it might work alright, then suddenly it zooms at a completely different speed, and just makes it impossible to focus on the part I want.
    It's like max suddenly focus on something way in the distance. Seriously, please fix this.

  • peteristratepeteristrate commented  ·   ·  Flag as inappropriate

    SP2 fixed it, indeed.
    There are still a few inconsistencies, like when you zoom in wireframe mode and yuo can't point with the mouse on the object, Max doesn't know to what it should relate(as your mouse pointer points to infinity, through the wireframe of the object) so it relates to infinity, and the zoom steps are too big.
    Same goes for pan and rotation too sometimes. But it's still better than it was before the SP2 and doesn't render Max2015 unusable.

  • kanga007kanga007 commented  ·   ·  Flag as inappropriate

    I had the unselected model tumble strangely and it got pretty lost in the viewport after a few rotations. I like to tumble my unselected objects to inspect the wireframe. SP2 fixed everything for me. :)

  • mats.holmbergmats.holmberg commented  ·   ·  Flag as inappropriate

    I'd very much like a comment from ADSK about this. This thing is driving me absolutely crazy! Going back to max2014 just to get rid of this.

    Also, in reply to MartinB: The idea to "help with situations where you have a large scene and get very close into some detail" was not needed, imo.
    I never experienced any problems when using "zoom selected" then using "orbit view" and pan to navigate around the selected object/subobject. Not sure if the other orbit modes caused problems, but "normal" orbit didn't.

    But please please please, just add an option for "use old style viewport navigation" and the problem is solved.

  • NeurologicalNeurological commented  ·   ·  Flag as inappropriate

    ohhhh my gosh, i've been pulling my damn hair out trying to figure out why the viewport-panning is so incredibly all-over the place.

    not only am i experiencing the orbit-tool problems, but also the whole 'pan-speed-depends-on-where-you-click' thing is HORRENDOUSLY obnoxious, and i haven't been able to find a way of switching back to the old version.

    if anyone knows of a way to make the viewport-panning work like it used to, holy fuck, please let me know O_O, i'm taken out of my work-groove CCOONSTANTLY with spats of frustration of how annoyingly broken this new pantool is.

  • mats.holmbergmats.holmberg commented  ·   ·  Flag as inappropriate

    Please Autodesk, note this: Never deploy a new feature without giving us users (your customers, we who pay for your product) an option to keep functionality to what we are used to.

  • 3dboomerang3dboomerang commented  ·   ·  Flag as inappropriate

    (btw vote is not to fix this, it's the wrong place, this vote is to REVERT TO THE OLD SYSTEM)


  • mats.holmbergmats.holmberg commented  ·   ·  Flag as inappropriate

    Just installed 2015 and this bug was apparent to me immediately. Just fix it now, ok? If it was up to me, I'd revert to the 2012 viewport, which is by far the most reliable one. (Stil have 2012 installed to do the bulk of my modelling.)

← Previous 1

Feedback and Knowledge Base